Hover Bovver

by | Nov 17, 2018 | Development, News | 0 comments

Just made a change to the way that links behave when you hover over them.

Long-time users will know that, by default, Textise previously displayed an underline on links when you hovered over them in the text-only output. In the interests of improved accessibilty, links are now outlined. This is way of indicating focus.

I’m aware that not everyone will want their links outlining, of course, so you can switch back to underline on the Options Page. Futhermore, returning users should find that their previous settings are retained (that is, links are underlined on hover). For new users, outline is the new default.

Colours are a thing when you’re outlining elements on a web page because of the challenge of maintaining visibility and contrast. The compromise I’ve hit, bearing in mind that the permutations of font colour/background colour are numerous, is to specify a blue outline when font is black and background white (in other words, the default for a new user or someone who’s never made changes on the Options Page). For all other colour combinations, outlines are in the same colour as the font.

The Home Page and Options Page do, you’ll notice, also now display blue outlines when you hover over links and buttons – and this isn’t user-configurable.

For the time being, your browser’s default outline will show when you navigate the pages with a keyboard rather than the Textise outline. This is because that takes a bit more development time – but I’m on it! 🙂

EDIT: On reflection, I might leave the browser outlines during keyboard navigation as they are, especially now I’ve standardised the text-only output to use the same hover colour.

Bad programmer excuses #1 
To be honest, at the time of writing, outlines aren’t working for me on the Home Page but I’m assuming it’s just a caching problem…

EDIT: Fixed now, but only by replacing external stylesheet with internal.

Bad programmer excuses #2 You might notice that some links in the text-only output stubbornly refuse to show an outline on hover, in spite of the fact that they’re perfectly happy to be underlined. At the moment, I have no idea why this is. Perhaps because of embedded divs? Or a CSS bug? Answers on a postcard (or a comment, if that’s your bag).

0 Comments

Submit a Comment

Your email address will not be published. Required fields are marked *

Recent Comments

Archives